Archive

Posts Tagged ‘ATi Radeon 4670’

The Fedora Megapost

September 3rd, 2009 2 comments

As I sit here writing this I am enjoying the more simple things in life. A fully functional laptop, graphical desktop effects, a strong network connection, decent battery life, and a touchpad that works completely. Ah, but things were never always this easy. No, in fact the last 3 days have taken me through a roller coaster ride of the high peaks and endless lows of my Fedora experience thus far. Allow me to take you through the story of how I got here, and hopefully this will help out people who aren’t quite here yet.

Painless Install

If there’s one thing I can say in Fedora’s favour its that the install went just perfectly. In fact the one part that I thought might be difficult, the partitioning, turned out to be the easiest. Fedora prompted me to select if I wanted the system encrypted via a checkbox or not and then if I wanted to review the default partition choices. Upon review the default partitions nearly matched the ones I thought I was going to create anyway. This includes an ext3 boot partition and an encrypted partition holding a LVM with the rest of my system partitions; an ext4 root and swap partitions.

On the next page I was able to select which software categories I wanted to install, and then customize exactly what that means. I chose to deselect GNOME and select KDE as my desktop environment. I also installed some software development tools, a web server (for fun), and SAMBA support to play nicely on the Windows network.

After entering a countless number of passwords, for the bootloader, the encrypted partition, the root account, and my user account, the system was finished installing and I was presented with my desktop! All told it too about 20 minutes to install – very quick and very impressive.

First Impressions

The K Desktop Environment (KDE) is something that I am very unfamiliar with. It took me about an hour to find my way around it and to be honest I hated it at first. I found it very clunky and some dialogue boxes were too small to show the text that they were trying to show me. Since then though it is starting to grow on me, though I am not sure if I would go with KDE over GNOME again in the future.

Now to Enable Those Fancy Desktop Effects I’ve Been Hearing So Much About

A simple check in the Desktop tab of the System Settings menu and Desktop Effects are enabled!…. COULD NOT ENABLE DESKTOP EFFECTS? If only I had known that this would be the start of all of my problems…

OK So Maybe I Need A Graphics Driver?

After poking around online for a while I finally gave up and just went to the ATi website and grabbed the driver from there. This graphical install was straightforward enough and when it finished everything seemed great! That is until I restarted and tried to turn effects on again. It turns out that there is a bug somewhere that freezes the system if hardware cursor is enabled, which it is by default. Disabling hardware cursor and enabling software rendering makes the system stable again, even with desktop effects, but causes graphics abnormalities around the cursor on the screen.

To enable the software cursor I first dropped down to the terminal from the login splash screen. To do this I used

Ctrl + Alt + F2

Next I logged in as root and changed /etc/X11/xorg.conf and added Option “SWCursor” “true” to the “Device” section as shown below,

Section “Device”
Identifier  “Videocard0″
Driver      “fglrx”
Option      “OpenGLOverlay” “off”
Option      “VideoOverlay” “on”
Option      “SWCursor” “true”
Option      “AccelMethod” “xaa”
EndSection

I also tried switching from OpenGL to XRender which seemed to fix things but its performance was all over the map, causing the system to slow to a crawl at times. -sigh- Guess I’ll just reinstall…

Round Two, Three, Four, Five, Six, etc!

I will skip through most of the 2 days worth of cursing that I went through to get everything set up correctly. Needless to say I tried everything from patching the kernel, to using open source drivers, to sacrificing a goat and nothing seemed to work. In the end it was a series of small steps that eventually led to my graphics card working. Here are some of the high points:

RPM Fusion

Following the advice of this FAQ over at FedoraFAQ.com, I used their community wrapped version of the ATi drivers that I had tried initially. Well at least I tried to, you see when I ran the following line it told me the package didn’t exist.

yum install kmod-fglrx

After more time spent googling I found out that the new name for it was ‘kmod-catalyst’, just like how ATi names it. It would have been nice for the authors at FedoraFAQ to update this in their old article but alas.

I patched and rebuilt the kernel and then rebooted. To my amazement my resolution was no longer very small. In fact I had my full 900p resolution! If that worked surely Desktop Desktop effects will as well! A quick jump to the Desktop settings tab and a check of the checkbox and I had effects up and running! Well… for about 20 seconds until my entire system locked up. Like, we’re talking a hard lock here. I couldn’t even kill X or drop down to the terminal to try and turn software cursor on. -sign- reboot and see if it worked? Nope, no luck there either. Well guess I will just reinstall then…

RPM Fusion Take Two!

After finishing the reinstall I found this new forum post with updated instructions. Great! I thought and followed them to the letter. Too bad this worked even less than before. Again I was forced to reinstall.

Skip All That Crap, Tell Us What Finally Worked!

Here is the process I took to get this to work, hopefully it will help some of you as much as it did me! I didn’t follow any particular instructions but rather mixed and matched ones that seemed to work. As such I don’t really know what each piece does but I have a general idea.

Step 1

Update the system, especially the kernel, to the most recent release.

Step 2

Bringing up a terminal I typed

su

To become the root user. Next I typed

yum install kmod-catalyst-2.6.29.6-217.2.16.fc11.x86_64.x86_64

This downloaded and installed the ATi driver catalyst kernel module for Fedora 11 x64. Next I shut down X using

init 3

Logging back into root I enabled the catalyst driver

catalyst-config-display enable

Finally I rebuilt the kernel so that it loaded the drivers correct.

new-kernel-pkg –mkinitrd –update $(rpm -q –queryformat=”%{version}-%{release}.%{arch}\n” kernel | tail -n 1)

Remember that’s two dashes before mkinitrd, update and queryformat! At this point you may have noticed that so far I am following the exact same process as I did during my first attempt with RPM Fusion. That is because this series of steps is the only one that gave me working hardware and good resolution.

OK So How Come It Worked This Time?

If you’ll remember it was at this point that when I enabled Desktop Effects my system would freeze up. setting Software Cursor in X seemed to fix this but caused other graphical issues. I managed to find this awesome post much later on in the giant Fedora Forum post that showed much promise. By opening a root terminal and typing,

aticonfig –set-pcs-str=”DDX,EnableRandR12,FALSE”

all of my problems were suddenly gone. Again that’s two dashes in front of set-pcs-str, not one! Now I’m not a rocket scientist but I think I just enabled random to make this work? :P This little line is a godsend. I was now able to enable full OpenGL graphical effects, including my desktop ones, without software cursor screwing everything up! Finally all of my countless hours of frustration paid off in spades!

Up Next: Full Touchpad Support

I honestly don’t even remember the whole process I went through to try and get my touchpad to support tap-clicking. My time spent on this task was intertwined between my time spent trying to fix my graphics issues. Needless to say all I had to do was verify that the synaptics driver was installed, it was, and then add this to /etc/X11/xorg.conf

Section “InputDevice”
Identifier  “Synaptics Touchpad”
Driver      “synaptics”
Option      “SendCoreEvents” “true”
Option      “Device” “/dev/psaux”
Option      “Protocol” “auto-dev”
Option      “HorizScrollDelta” “0″
Option      “SHMConfig” “true”
Option      “TapButton1″ “1″
EndSection

And then set up a terminal command to run on startup that executes the following line:

synclient TapButton1=1

So What’s Next?

Amazingly I think I am almost completely set-up and ready to start actually using my system in a normal way. My networking works, my graphics work, my audio works, it all seems to just work.

Are You Sure?

Well… there are two little annoying things.

Network Manager and KWallet

The first time I installed Fedora, a program called KWallet, the KDE password manager, stored my Wifi password perfectly. Now however for some reason it is not storing the password at all which forces me to enter it every time I want to connect to the network. This is incredibly annoying and should be an easy fix but I just cannot seem to find a way to make it start remembering my password! If anyone knows how to make it suddenly smarten up please let me know!

Kopete and Webcam

I never had any reason to use a webcam in an instant messenger however while poking around inside of Kopete I did notice that it seemed to support it. So I hopped on MSN and attempted to test this capability. Only… I can’t find the button to send or receiver webcam invites anywhere. Does Kopete just not support MSN webcam? A quick google search seems to claim it does… Again if anyone knows the answer to this or how to make it work please post a comment. :)

Conclusion

Sorry for the long post but I figured I might as well catch up on everything I had missed writing in the past couple of days. Here is a picture of my desktop just to prove it actually works as promised :P

My Desktop

My Desktop