Archive

Posts Tagged ‘Intel’

Very short plug for PowerTOP

July 4th, 2010 1 comment

Recently I decided to try out PowerTOP, a Linux power saving application built by Intel. I am extremely impressed by how easy it was to use and the power savings I am now basking in.

PowerTOP is a terminal application that first scans your computer for a number of things during a set interval. It then reports back which processes are taking up the most power and offers you some options to improve your battery life. All of these options can literally be enabled at a press of a button. It’s sort of like an experience I once had with Clippy in Microsoft Word; “it seems you are trying to save power, let me help you…” After applying a few of the suggestions the estimated battery life on my laptop went from about 3 and a half hours to almost 5 hours. In short, I would highly recommend everyone at least try out PowerTOP. I’m not promising miracles but at the very least it should help you out some.




I am currently running a variety of distributions, primarily Linux Mint Debian Edition.
Previously I was running KDE 4.3.3 on top of Fedora 11 (for the first experiment) and KDE 4.6.5 on top of Gentoo (for the second experiment).
Check out my profile for more information.

Learning to live with XFCE

October 24th, 2009 2 comments

There’s no doubt that when I initially switched from GNOME to XFCE, I was pretty angry. But hey, you can’t stay mad forever – In time, I’ve learned to appreciate GNOME’s minimalistic cousin for what it is, and (unlike some of the other guys) haven’t yet decided whether or not I’ll be switching back to GNOME tomorrow.

Sure, XFCE was a pain to get set up, but since then, it’s been fast and exceedingly stable. As a point of comparison, while running GNOME, I experienced daily crashes related to a known issue between Compiz and my Intel integrated video card. On XFCE, this issue has yet to manifest itself, although this may also have something to do with all of the upgrades that I made the day before changing desktop environments. With the addition of Compiz, GnomeDo+Docky, and some minor customization, I’ve created a desktop that is pleasing to look at, but remains responsive and lightweight on my aging hardware.

My only major complaint with XFCE remains the organization of the “Start Menu.” While I initially thought that the idea of separate Application, Places, and System menus in GNOME were stupid (having come from a Windows background), I find myself missing them under XFCE. I find their single menu system cluttered and hard to navigate, even with it’s sub-menus. GnomeDo improves things, but only if you know the name of the feature or setting that you’re searching for.

On the other hand, the GNOME community has just released a new version of their desktop environment, and it seems to include some neat new features. More importantly, the GNOME community has done a lot of thinking about where they want to take v3.0, due for release in either March or September of 2010. Some of the most interesting ideas that have come from this brainstorming (in my mind anyway), are a new desktop paradigm, supported mainly by a new compositing engine called Gnome Shell, and a new way of browsing your files called Gnome Zeitgeist. Check out some early demo screens here.

Hell, I might even consider taking the KDE plunge, just to see what all of the rage is about…




On my Laptop, I am running Linux Mint 12.
On my home media server, I am running Ubuntu 12.04
Check out my profile for more information.

My audio doesn’t work anymore

September 21st, 2009 1 comment

Yup. Not sure why. It just happened. I have tried messing around in my audio settings and still nothing. In fact the only audio device I can get to play is not PulseAudio, or anything standard like that, but rather the Intel audio card that it found for my system. While this is all fine and promising it still doesn’t work right. When I tried to set it as my primary device and restarted my machine KDE threw a bunch of error messages my way saying that it couldn’t use the Intel device (really? because that was the only one that worked for me…) and instead fell back to PulseAudio (really? because that one doesn’t work for me…).

Why is it that Linux works great for a short while and then suddenly breaks itself?