Archive

Posts Tagged ‘mesa-utils’

Graphical Woes and a Bricked System

September 2nd, 2009 1 comment

Today’s big task was to get rid of the Windows 3.1 look of the default GNOME theme by installing the Compiz Fusion window manager. First, however, I needed to add 3D hardware acceleration and OpenGL support to my existing graphics system. Unfortunately, after an evening of searching for how to accomplish these seemingly simple tasks in Google’s proverbial haystack of information, I found myself no wiser, and in the mood to chew through my power cable and just end it all.

Bleary-eyed and pissed off, I turned to the community in the #debian IRC channel for help, and found a room full of knowledgeable folks who were very willing to help me out. Sometime during the ensuing discussion, I followed this guy’s advice and installed a package called mesa-utils that added OpenGL support to my system, and was good to go. The only problem is that I don’t know if I could do it again, because I can’t recall the steps that got me to where I am. Damn.

In any case, with hardware acceleration now supported, I moved on to enabling the Compiz Fusion window manager with this tutorial on the Debian Wiki. Unfortunately, upon activating my newly installed eye candy, my entire system froze up. I restarted X, but the service refused to come back online, and was disabled by the system.

Now, whenever I attempt to boot my laptop, I get a big error message claiming that X failed to start, and can’t get into my desktop. It seems that the changes that I made to the /etc/X11/xorg.conf file while setting up Compiz have caused an error that occurs while parsing the file on startup.

So, I guess my install is bricked until I can remove my changes to that config file… Anybody got a live CD?