Archive

Archive for September 3rd, 2009

Finally Up and Running

September 3rd, 2009 1 comment

As you may recall, last night, I ruined my system by manually editing the xorg.conf config file according to a sketchy tutorial on the Debian Wiki. This evening, I fixed the problem and got Compiz effects running in all of 20 minutes. The moral of the story: Before fucking about online, use the resources that are right in front of you.

Firstly: Fixing X

When I edited the xorg.conf file last night, I made a mistake, and every time X tried to load on startup, it failed out. At the time, I was bleary-eyed and half in the bag, and didn’t realize that when this happened, Debian presented me with the ability to log into the terminal and fix my silly mistakes.

Refreshed and ready to go, I logged into the terminal as root this evening, loaded the config file in question, took out my changes, saved, and restarted. Lo and behold, everything worked perfectly, and I got my desktop back.

Part B: Getting Compiz

After enabling OpenGL support and 3D hardware acceleration last night, I immediately attempted to get the Compiz suite of relatively useless eye candy nonsense up and running, a process that lead directly to me bricking my system.

The first tutorial that I tried to follow last night instructed me to edit my sources list and download the required packages from a third-party mirror… Until I scrolled down (after already doing all of the suggested actions), and realized that the entire tutorial was outdated because Compiz had since been migrated into the Debian repositories. I more or less succeeded in disabling all of those changes, in the sense that undoing them didn’t break anything apparent.

The next step was a quick dash over to the Debian Wiki for information on how to install Compiz properly, which I assumed could be had from this tutorial. Turns out I was wrong, because while the package installs that it reccomends mostly succeeded, when I tried to enable Compiz, it errored out and locked up my desktop.

Pissed off, I tried making the suggested changes to the xorg.conf file that are suggested in the tutorial, which to my dismay, resulted in X locking up because of errors in my freshly edited config file. This brings us roughly to where I was at with last night’s post.

Once I had restored my desktop and come to my senses, getting Compiz was actually a snap. I launched the Aptitude package manager from a root terminal, searched for the Compiz package, and let it take care of handling any dependencies and conflicts for me. In the process, it handily uninstalled a few garbage packages that I had added last night while fucking things up.

With Compiz properly installed, I used the Synaptic package manager (the graphical front-end to Aptitude) to add the Fusion Icon package (a Compiz control icon) to my taskbar for easy access, and sat back to have a celebratory beer and enjoy me some Wobbly Windows. Another moral for the story: The Debian Wiki sucks, and has lead me astray one too many times. From here on in, I will take everything that it claims with a truckfull of salt.

(Supposed) Icing on the Cake: Screenlets

Lastly, I added the Screenlets package, which allows me to have Vista-like widgets on my desktop that do silly things like monitoring my internals and wasting my system resources. So far, I’ve found the default screenlets to be pretty lame and useless, and I don’t quite understand the process of installing a new screenlet yet. I’ll get back to this in a later post.

How to add audio and video codecs to Fedora 11

September 3rd, 2009 3 comments

By default this distro does not support non-free codecs. After a quick google search I found this quick and easy solution to add audio and video codecs to my Fedora install. Thanks again Tech Jaws.

In a root terminal run these commands

rpm -Uhv http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-rawhide.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-rawhide.noarch.rpm

and

yum install gstreamer-plugins-bad gstreamer-plugins-ugly

That should do it! Full MP3 support!

[UPDATE] I noticed that MP3 support wasn’t working in Amarok so after some googling I corrected this problem by also installing the following.

yum install libtunepimp-extras-nonfree
yum install xine-lib-extras-nonfree

Linux Mint

September 3rd, 2009 1 comment

I picked a distribution at random, and Linux Mint turned out to be a pretty good choice for someone like me – ie, completely incompetent with electronics.

Installation

The installation was actually really quick, easy, and painless. It consisted of a few clicks, a few passwords, and that was about it really. Almost everything I needed was installed from the beginning, and installing programs, drivers, etc, turned out to be very simple thanks to the assorted managers. The main issue I’ve run into is compatilibility – right now I’m struggling to figure out how to get EnigMail to work in Thunderbird (the program claims that it is not supported for 64-bit Linux) – [resolved while typing this post].

Software

So far, most of the software I use is open source (Firefox, Thunderbird, R) or already has an open source alternative (Open Office). However, this doesn’t mean that the alternatives are solid replacements for their proprietary inspirations. Take Windows Live Messenger and the Plus! extension. While aMSN gets the job done and has webcam support, it doesn’t offer creature comforts like floating desktop contacts, merged consecutive messages, or support for games with Windows Live contacts. I also completely forgot that most fonts are proprietary – my beloved Georgia is gone!

One of the more annoying things is that I can’t figure out how the hell to access R. Unlike my other programs, I had to install this through the terminal, and it doesn’t appear in my list of applications. Installing it always confused me even when I used it in Windows, so I’ll probably have to work at it a bit before I get anywhere.

My main gripe with all of this free software is that, frankly, it looks like crap. Every program seems dull and grey, and if you want to change it, you need to go and get a plug-in. I’m currently running Mint with the Max OS X theme because I couldn’t stand how everything looked. I tried the Vista theme, but it just wasn’t working, so I gave up, whored out, and went crawling to Apple (sort of, anyway). As I mentioned before, a lot of the applications are missing creature comforts – stuff like having the play/pause key be the same in RhythmBox, or having those stupid little taglines in Windows Live Messenger. In no way do I require these features, but it’s little things like this that keep a user interested in a product. We’re all quite easily distracted by blinkenlights.

Installing and  updating software was extremely easy. I went into the either mintInstall, mintUpdate, or the package manger and got what I needed. I used the package manager to install R, but found that it didn’t have the latest version, so unfortunately I had to install it through the terminal.

Media

Linux Mint came with several media players and codecs installed, and they all worked very well. Unfortunately, my two preferred video players (The Core Media Player and Media Player Classic) don’t have Linux versions. The default players are decent enough and I’m definitely familiar with VLC, but my videos seem to run slowly when they’re in windowed mode. It’s not choppy by any means, but there’s a noticeable difference between full-screen and windowed mode. Switching between full-screen and windowed mode did have an odd issue – when going between them, my machine would briefly flash the desktop at me. Seeing as this is Linux, though, I think the most important thing to mention is that my videos worked, and they worked on the first try.

In my opinion, RhythmBox is about as easy to use as iTunes, with the added feature that when I add songs, the program actually adds their names properly.

Hardware

My external hard drive worked perfectly – the OS instantly recognized it and I could use it to my heart’s content. Similarly, when I popped in my SD card, it appeared on my desktop and I could view everything. The webcam works as desired, and the effects available are far more impressive than the crap Dell offers. Linux Mint lets you throw in “filters”, if you will, and you can combine them. For example, you can blur motion and have the room move (as if you were dizzy), creating an excellent inebriation simulator. Dell’s default (and Vista’s too I guess) simply superimposes a cheesey image reminiscent of clipart so you look like you’re in a spaceship or some dumb shit like that. Overall, I’m very impressed with what I can do, especially after hearing Jake and Jon curse for several days about trivial issues like getting the mouse to work.

On a negative note, the OS seems to have trouble finding my monitor. Whenever I try to detect it, the system slows down significantly and never seems to get anywhere. I’m not sure if this is because it needs an updated driver and it’s not working correctly, or if this is standard for a first-time installation.

Other issues

Linux seems to be fond of flashing me. When I switch between full-screen and windowed mode in any of my media players, it briefly flashes the desktop at me and then works as desired. Occasionally the bottom part of my browser goes black for a short period of time. And the jelly windows, while fantastic in their novelty, have a minor issue where the borders look grainy while I’m jiggling them. Yes, I’m a superficial consumer whore.

I’ve also had to endure a few slowdowns at seemingly random intervals. I’m not sure what causes them, but it’s probably one of my useless Firefox widgets.

Overall

All in all my experience with Linux Mint has been positive. I don’t think I’ll stick with Linux for too long (meaning I’ll end up with Vista soon), but so far Mint has impressed me. At the very least, I’ll almost certainly have Linux Mint on my computer for a VM. I’m impressed with how easy and intuitive the system has been for me – while I’ve had experience with computers and different operating systems, I’m still a newbie at most computer-related tasks, so being able to survive the installation and configuration of Mint and coming out relatively unscathed has been a major boon.

Categories: Linux Mint, Sasha D Tags:

The Fedora Megapost

September 3rd, 2009 2 comments

As I sit here writing this I am enjoying the more simple things in life. A fully functional laptop, graphical desktop effects, a strong network connection, decent battery life, and a touchpad that works completely. Ah, but things were never always this easy. No, in fact the last 3 days have taken me through a roller coaster ride of the high peaks and endless lows of my Fedora experience thus far. Allow me to take you through the story of how I got here, and hopefully this will help out people who aren’t quite here yet.

Painless Install

If there’s one thing I can say in Fedora’s favour its that the install went just perfectly. In fact the one part that I thought might be difficult, the partitioning, turned out to be the easiest. Fedora prompted me to select if I wanted the system encrypted via a checkbox or not and then if I wanted to review the default partition choices. Upon review the default partitions nearly matched the ones I thought I was going to create anyway. This includes an ext3 boot partition and an encrypted partition holding a LVM with the rest of my system partitions; an ext4 root and swap partitions.

On the next page I was able to select which software categories I wanted to install, and then customize exactly what that means. I chose to deselect GNOME and select KDE as my desktop environment. I also installed some software development tools, a web server (for fun), and SAMBA support to play nicely on the Windows network.

After entering a countless number of passwords, for the bootloader, the encrypted partition, the root account, and my user account, the system was finished installing and I was presented with my desktop! All told it too about 20 minutes to install – very quick and very impressive.

First Impressions

The K Desktop Environment (KDE) is something that I am very unfamiliar with. It took me about an hour to find my way around it and to be honest I hated it at first. I found it very clunky and some dialogue boxes were too small to show the text that they were trying to show me. Since then though it is starting to grow on me, though I am not sure if I would go with KDE over GNOME again in the future.

Now to Enable Those Fancy Desktop Effects I’ve Been Hearing So Much About

A simple check in the Desktop tab of the System Settings menu and Desktop Effects are enabled!…. COULD NOT ENABLE DESKTOP EFFECTS? If only I had known that this would be the start of all of my problems…

OK So Maybe I Need A Graphics Driver?

After poking around online for a while I finally gave up and just went to the ATi website and grabbed the driver from there. This graphical install was straightforward enough and when it finished everything seemed great! That is until I restarted and tried to turn effects on again. It turns out that there is a bug somewhere that freezes the system if hardware cursor is enabled, which it is by default. Disabling hardware cursor and enabling software rendering makes the system stable again, even with desktop effects, but causes graphics abnormalities around the cursor on the screen.

To enable the software cursor I first dropped down to the terminal from the login splash screen. To do this I used

Ctrl + Alt + F2

Next I logged in as root and changed /etc/X11/xorg.conf and added Option “SWCursor” “true” to the “Device” section as shown below,

Section “Device”
Identifier  “Videocard0″
Driver      “fglrx”
Option      “OpenGLOverlay” “off”
Option      “VideoOverlay” “on”
Option      “SWCursor” “true”
Option      “AccelMethod” “xaa”
EndSection

I also tried switching from OpenGL to XRender which seemed to fix things but its performance was all over the map, causing the system to slow to a crawl at times. -sigh- Guess I’ll just reinstall…

Round Two, Three, Four, Five, Six, etc!

I will skip through most of the 2 days worth of cursing that I went through to get everything set up correctly. Needless to say I tried everything from patching the kernel, to using open source drivers, to sacrificing a goat and nothing seemed to work. In the end it was a series of small steps that eventually led to my graphics card working. Here are some of the high points:

RPM Fusion

Following the advice of this FAQ over at FedoraFAQ.com, I used their community wrapped version of the ATi drivers that I had tried initially. Well at least I tried to, you see when I ran the following line it told me the package didn’t exist.

yum install kmod-fglrx

After more time spent googling I found out that the new name for it was ‘kmod-catalyst’, just like how ATi names it. It would have been nice for the authors at FedoraFAQ to update this in their old article but alas.

I patched and rebuilt the kernel and then rebooted. To my amazement my resolution was no longer very small. In fact I had my full 900p resolution! If that worked surely Desktop Desktop effects will as well! A quick jump to the Desktop settings tab and a check of the checkbox and I had effects up and running! Well… for about 20 seconds until my entire system locked up. Like, we’re talking a hard lock here. I couldn’t even kill X or drop down to the terminal to try and turn software cursor on. -sign- reboot and see if it worked? Nope, no luck there either. Well guess I will just reinstall then…

RPM Fusion Take Two!

After finishing the reinstall I found this new forum post with updated instructions. Great! I thought and followed them to the letter. Too bad this worked even less than before. Again I was forced to reinstall.

Skip All That Crap, Tell Us What Finally Worked!

Here is the process I took to get this to work, hopefully it will help some of you as much as it did me! I didn’t follow any particular instructions but rather mixed and matched ones that seemed to work. As such I don’t really know what each piece does but I have a general idea.

Step 1

Update the system, especially the kernel, to the most recent release.

Step 2

Bringing up a terminal I typed

su

To become the root user. Next I typed

yum install kmod-catalyst-2.6.29.6-217.2.16.fc11.x86_64.x86_64

This downloaded and installed the ATi driver catalyst kernel module for Fedora 11 x64. Next I shut down X using

init 3

Logging back into root I enabled the catalyst driver

catalyst-config-display enable

Finally I rebuilt the kernel so that it loaded the drivers correct.

new-kernel-pkg –mkinitrd –update $(rpm -q –queryformat=”%{version}-%{release}.%{arch}\n” kernel | tail -n 1)

Remember that’s two dashes before mkinitrd, update and queryformat! At this point you may have noticed that so far I am following the exact same process as I did during my first attempt with RPM Fusion. That is because this series of steps is the only one that gave me working hardware and good resolution.

OK So How Come It Worked This Time?

If you’ll remember it was at this point that when I enabled Desktop Effects my system would freeze up. setting Software Cursor in X seemed to fix this but caused other graphical issues. I managed to find this awesome post much later on in the giant Fedora Forum post that showed much promise. By opening a root terminal and typing,

aticonfig –set-pcs-str=”DDX,EnableRandR12,FALSE”

all of my problems were suddenly gone. Again that’s two dashes in front of set-pcs-str, not one! Now I’m not a rocket scientist but I think I just enabled random to make this work? :P This little line is a godsend. I was now able to enable full OpenGL graphical effects, including my desktop ones, without software cursor screwing everything up! Finally all of my countless hours of frustration paid off in spades!

Up Next: Full Touchpad Support

I honestly don’t even remember the whole process I went through to try and get my touchpad to support tap-clicking. My time spent on this task was intertwined between my time spent trying to fix my graphics issues. Needless to say all I had to do was verify that the synaptics driver was installed, it was, and then add this to /etc/X11/xorg.conf

Section “InputDevice”
Identifier  “Synaptics Touchpad”
Driver      “synaptics”
Option      “SendCoreEvents” “true”
Option      “Device” “/dev/psaux”
Option      “Protocol” “auto-dev”
Option      “HorizScrollDelta” “0”
Option      “SHMConfig” “true”
Option      “TapButton1″ “1”
EndSection

And then set up a terminal command to run on startup that executes the following line:

synclient TapButton1=1

So What’s Next?

Amazingly I think I am almost completely set-up and ready to start actually using my system in a normal way. My networking works, my graphics work, my audio works, it all seems to just work.

Are You Sure?

Well… there are two little annoying things.

Network Manager and KWallet

The first time I installed Fedora, a program called KWallet, the KDE password manager, stored my Wifi password perfectly. Now however for some reason it is not storing the password at all which forces me to enter it every time I want to connect to the network. This is incredibly annoying and should be an easy fix but I just cannot seem to find a way to make it start remembering my password! If anyone knows how to make it suddenly smarten up please let me know!

Kopete and Webcam

I never had any reason to use a webcam in an instant messenger however while poking around inside of Kopete I did notice that it seemed to support it. So I hopped on MSN and attempted to test this capability. Only… I can’t find the button to send or receiver webcam invites anywhere. Does Kopete just not support MSN webcam? A quick google search seems to claim it does… Again if anyone knows the answer to this or how to make it work please post a comment. :)

Conclusion

Sorry for the long post but I figured I might as well catch up on everything I had missed writing in the past couple of days. Here is a picture of my desktop just to prove it actually works as promised :P

My Desktop

My Desktop