Archive

Posts Tagged ‘x’

Graphical Woes and a Bricked System

September 2nd, 2009 1 comment

Today’s big task was to get rid of the Windows 3.1 look of the default GNOME theme by installing the Compiz Fusion window manager. First, however, I needed to add 3D hardware acceleration and OpenGL support to my existing graphics system. Unfortunately, after an evening of searching for how to accomplish these seemingly simple tasks in Google’s proverbial haystack of information, I found myself no wiser, and in the mood to chew through my power cable and just end it all.

Bleary-eyed and pissed off, I turned to the community in the #debian IRC channel for help, and found a room full of knowledgeable folks who were very willing to help me out. Sometime during the ensuing discussion, I followed this guy’s advice and installed a package called mesa-utils that added OpenGL support to my system, and was good to go. The only problem is that I don’t know if I could do it again, because I can’t recall the steps that got me to where I am. Damn.

In any case, with hardware acceleration now supported, I moved on to enabling the Compiz Fusion window manager with this tutorial on the Debian Wiki. Unfortunately, upon activating my newly installed eye candy, my entire system froze up. I restarted X, but the service refused to come back online, and was disabled by the system.

Now, whenever I attempt to boot my laptop, I get a big error message claiming that X failed to start, and can’t get into my desktop. It seems that the changes that I made to the /etc/X11/xorg.conf file while setting up Compiz have caused an error that occurs while parsing the file on startup.

So, I guess my install is bricked until I can remove my changes to that config file… Anybody got a live CD?

Sitrep – Fedora: 1. Dana’s patience: 0.

September 2nd, 2009 No comments

As you might be able to tell from the title of this post, I feel like I’m fighting an uphill battle here.  Through hummus.  In the middle of winter.  While I’m getting clawed back down the hill by a thousand lesbians.  Tempted to join them, but ever vigilant.

After much cajoling and terminal commands, I’ve managed to get the real (REAL!) nVidia graphics driver up and running.  While I was very excited for the ‘nouveau nVidia driver’ offered by default in Fedora 11, turns out this offers shit in the form of functionality with my graphics card.  No desktop effects and no ability to change screen brightness?  No thanks.

Hope eventually came in the form of a nice little .run file from nVidia’s site with the latest 64-bit drivers for my graphics card.  Hooray, I thought!  Sweet victory.  But wait, I’ve never seen a .run file before…?

*some searching*

Twenty minutes of Googling and tinkering later, and I figure out how to: 1) run a .run file, 2) kill X, and 3) work my way through the driver installation.  Which eventually failed, yes, but hey.  Five more minutes of Googling later and I came across this fantastic little site.  It gave me detailed, step-by-step instructions on how to add new repositories to yum (to which I’ve rather taken a liking), and from there getting the kmod-nvidia driver up and running.  Easy as pie!

Some time later, I’m now running with full desktop effects (shiny) in Gnome and the ability to change the brightness of my screen.  As far as other devices go, most things seem to work out of the box.  Touchpad and sound controls are fully functional, as well as some of my Fn+ keys (such as screen brightness and mute).  It’s been fun so far.

Next up: networking.  Might need some help here…

I am currently running Gnome 2.26 on top of Fedora 11 (Leonidas). Check out my profile for more information.